Quantcast
Channel: UNIX and Linux Forums - AIX
Viewing all 373 articles
Browse latest View live

Help with clear printer queue script in AIX 5.3

$
0
0
Good day UNIX forum, could you help me with my clear printer queue script, i have problems with the consistency of this function, sometimes it works sometimes it doesn't. Thanks in advance

Code:

}

preRemovePrintQ(){

clear;
echo;
echo "==============================================================================";
echo "### R E M O V E    P R I N T E R    Q U E U E";
echo "==============================================================================";
echo; echo;
echo "Enter print queue for removal: \c";
read queName;

while [ ! "$queName" ]
do
  echo "Enter print queue for removal: \c";
  read queName;
done

queNameT=`echo "$queName"|tr -cd [:alnum:]|tr A-Z a-z`;
preRemovePrintQ2;

}

preRemovePrintQ2(){

lsque -q $queNameT > /dev/null 2>&1;
if [ "$?" -eq "0" ]; then
  echo;
  echo "Are you sure you want to remove this print queue [yes/no]? \c";
  read prqAnswer;
  preRemovePrintQ3;
else
  echo;
  echo "Print queue \"$queNameT\" does not exists. Do want to try again [yes/no]? \c";
  read tryagain;
  tryagainAnswer;
fi;

}

 
tryagainAnswer(){

case "$tryagain" in
    YES|yes|Yes|YeS|yeS|YEs|yES|yEs)
    preRemovePrintQ;
        ;;
    NO|no|No|N|n|nO)
    pause;
        ;;
  *)
    echo "Please answer [\"yes\" or \"no\"]: \c";
        read tryagainAnswer;
        tryagainAnswer;
        ;;
esac;

}


preRemovePrintQ3(){

 case "$prqAnswer" in
    YES|yes|Yes|YeS|yeS|YEs|yES|yEs)
    goremovePrinterQue;
        ;;
    NO|no|No|N|n|nO)
    pause;
        ;;
  *)
    echo "Please answer [\"yes\" or \"no\"]: \c";
        read prqAnswer;
        preRemovePrintQ3;
        ;;
esac;
 
}

goremovePrinterQue(){

for qHere in `ls /var/spool/lpd/qdir/ | grep "$queNameT"`; do rm -f $qHere; done;

DevNam3=`lsque -q $queNameT|grep "device"|awk -F\= '{print $2}'|sed -e 's/^[ \t]*//'`;
/usr/lib/lpd/pio/etc/piomisc_ext rmpq_other  $queNameT:$DevNam3 'remote.local';
echo;
echo "-----------------------------------------------------------------";
echo "Printer queue \"$queNameT\" has been successfully removed. [OK].";
echo "-----------------------------------------------------------------";
echo;

}


Help with adding new disks in HACMP

$
0
0
Hi

Below are the new luns added by the storage team. My cluster setup is a three node HA cluster. I could see the below mentioned luns on all the three nodes :

Code:

hdisk26        00084dd0ef986943                    None
hdisk27        00084dd0ef988d1f                    None

and we tried to extend the shared volume group through the following steps.

smitty hacmp-->System Management (C-SPOC)-->HACMP Logical Volume Management -->Shared Volume Group-->set Characteristics of a shared volume group-->Add a volume to a shared volume group

We have selected the following shared volume group and resource name.

esbsirg3, sirg3vg1

then selected the new disks..i.e hdisk 26 and hdisk27. After hitting enter, we got the following error..

cl_extendvg: Error executing extendvg sirg3vg1 hdisk27 hdisk26 on node esbsit03

Can any one please advise why we get this error ?

IBMR2 backup server

$
0
0
I am building a backup IBMR2 server with AIX 4.3 operating system. The application uses a TUXEDO front end. I am getting an authorization error when I try to bring the system up with tpchkauth error. I need to know how to find the value of this field so I can compare it to my production server. Is there a simple way to do this? Am I going about this the wrong way? I know next to nothing about UNIX and AIX.

Moderator's Comments:
edit by bakunin: we have a special board for all things AIX. Your best chance for getting an answer is there and therefore i transfer this thread.

Mandatory FS for mksysb

$
0
0
Hi all,

my first post. Be kind to me and to my english writing (i'm french) :)

During mksysb backup, some files are moving. I don't know yet which files (i'm starting a new job). For now, i'm wondering which fs are mandatory for a mksysb backup.

Currently, hereafter the content of rootvg :
Code:

hd5                boot      1      2      2    closed/syncd  N/A
hd6                paging    66      132    2    open/syncd    N/A
hd8                jfs2log    1      2      2    open/syncd    N/A
hd4                jfs2      63      126    2    open/syncd    /
hd2                jfs2      95      190    2    open/syncd    /usr
hd9var              jfs2      25      50      2    open/syncd    /var
hd3                jfs2      16      32      2    open/syncd    /tmp
hd1                jfs2      4      8      2    open/syncd    /home
hd10opt            jfs2      26      52      2    open/syncd    /opt
hd11admin          jfs2      4      8      2    open/syncd    /admin
livedump            jfs2      8      16      2    open/syncd    /var/adm/ras/livedump
loglv02            jfslog    1      1      1    closed/syncd  N/A
lvnim02prod00      jfs2      4      8      2    open/syncd    /prod
lvnim02log00        jfs2      63      126    2    open/syncd    /log
lvnim02logNM00      jfs2      62      124    2    open/syncd    /lognmon

Have a nice day
Pat

AIX How to exchange hostname and IP address between two AIX servers?

$
0
0
Hi all,

I am trying to exchange hostname and IP address of two AIX machines.

But i am confused as how to change it ?
do i need to use "smitty mktcpip" or "smitty tcpip" ?

what is the difference between smitty mktcpip and smitty tcpip ?

Also anymore steps to follow or just updating using smitty is enough (hoping that no reboot is required)

Also below is the procedure i want to use for the whole process of swapping hostname and IP address:

1) remove server A from network and update hostname and IP address (to Server B's hostname and IP) using smitty

2) move network connection cables from server B to server A

3) update hostname and IP of server B (to that of server A's old values)

4) attach network cables removed from server A to server B

Does this procedure is good to go ?

Thanks in advance!

2nd SSH doesn't work with AD

$
0
0
Recently I decided to intall second daemon of SSH for Winbind users.
I mean I have configuration AIX + Samba + AD and I can login to the server via SSH with AD accounts to 22 port without any problems.
But now I have second installation of OpenSSH and don't understand why I can't do the same with that ?
I compiled it with :
$ ./configure --prefix=/opt/openssh --with-pam --with-kerberos5=/usr/krb5
$ make
$ make install
... and was nothing errors.

My config files on both daemons ssh is equal except Port (22 / 222)

Code:

$ cat /etc/ssh/sshd_config | egrep -v "(^#.|^$)"
Protocol 2
SyslogFacility AUTHPRIV
PermitRootLogin no
PasswordAuthentication yes
ChallengeResponseAuthentication yes
GSSAPIAuthentication yes
GSSAPICleanupCredentials yes
UsePAM yes
UseLogin yes
PermitUserEnvironment yes
PidFile /var/run/sshd.pid
Subsystem      sftp    /usr/sbin/sftp-server -e -l DEBUG3

On the second new one SSH I can login only with local users, but can't login with Winbind : (

Remote Script command logging question

$
0
0
I've noticed that when running a script that connects to a number of our servers (to essentially run batch commands) that the commands aren't logged in the user's .sh_history or .bash_history files. Is there a place where this is logged (assuming the script itself isn't doing the logging and I'm not tee'ing the output anywhere)?

I'm talking specifically about AIX, but I would assume this question applies to all the *nix flavors.


As a tag-along to this post, I often nohup these commands (like sendmail -bi) so the script can run through all the hosts quickly. What can I enter in the script to create one large nohup.out on the machine running the script that's reaching out to all the others?Right now I've got
Code:

for node in `cat /home/root/script/shortlist`
#for node in `cat /usr/local/bin/AIX_server_list`
do
echo $node
ssh $node lssrc -s sendmail
echo "***"
ssh $node cp /etc/aliases /etc/aliases.old
scp -p /etc/aliases $node:/etc/aliases
ssh $node nohup sendmail -bi &
ssh $node lssrc -s sendmail
ssh $node cat /home/root/nohup.out >> ~/script/sendmailbi_log.txt
echo "%%%%%%%%%%%%%%%%%%%%%%%%"
done

but that failed miserably, I'm guessing that's because the nohup was given via an ssh and not in an interactive shell so nothing got logged?

VIOS - Error 500: java.lang.OutOfMemoryError

$
0
0
Hey buddies,

I'd love to seek and destroy the cause of this error > . <

I get this in my browser (Error 500: java.lang.OutOfMemoryError) when I unsuccessfully try to access my Vios - IVM adress :(

To recover access to IVM adress I have to enter "oem_setup_env" mode and "kill -9 java's PID" (topas result attached - Java PgSp is usually over the value printed)

But after some time it happens again!

How can I proceed to solve this at once?

Thank you in advance.

Attached Images
File Type: png Topas Java Power7.png (36.3 KB)

AIX 6.1 New SP&TL 6.1.8.0 upgradation failed

$
0
0
Hello Team,

Hope all doing well. I have tried to upgrade on of my AIX box too the latest SP and TL, but unfortunately it's got failed(Details are below). Need expert help to fix this.


Code:

Before up-gradation :
root@[/roracle/AIX]# oslevel -s
6100-07-01-1141
root@[/roracle/AIX]# instfix -i | grep ML
    All filesets for 6100-00_AIX_ML were found.
    All filesets for 6100-01_AIX_ML were found.
    All filesets for 6100-02_AIX_ML were found.
    All filesets for 6100-03_AIX_ML were found.
    All filesets for 6100-04_AIX_ML were found.
    All filesets for 6100-05_AIX_ML were found.
    All filesets for 6100-06_AIX_ML were found.
    All filesets for 6100-07_AIX_ML were found.

While doing 'smitty upgrade_all' got failed . After reboot the machine the result's are below.

root@[/home/root]# oslevel -s
6100-07-03-1207
root@[/home/root]# instfix -i | grep ML
    All filesets for 6100-00_AIX_ML were found.
    All filesets for 6100-01_AIX_ML were found.
    All filesets for 6100-02_AIX_ML were found.
    All filesets for 6100-03_AIX_ML were found.
    All filesets for 6100-04_AIX_ML were found.
    All filesets for 6100-05_AIX_ML were found.
    All filesets for 6100-06_AIX_ML were found.
    All filesets for 6100-07_AIX_ML were found.
    All filesets for 6.1.0.0_AIX_ML were found.
    Not all filesets for 6100-08_AIX_ML were found.

root@[/home/root]# instfix -icqk  6100-08_AIX_ML | grep :-:
6100-08_AIX_ML:bos.net.uucp:6.1.8.0:6.1.7.0:-:AIX 6100-08 Update
6100-08_AIX_ML:devices.pciex.151438c1.rte:6.1.7.15:6.1.7.0:-:AIX 6100-08 Update
6100-08_AIX_ML:printers.ibmgb18030_CN.rte:6.1.8.0:6.1.6.0:-:AIX 6100-08 Update
6100-08_AIX_ML:printers.ibmuniversal.rte:6.1.8.0:6.1.6.0:-:AIX 6100-08 Update
root@[/home/root]# lppchk -v
lppchk:  The following filesets need to be installed or corrected to bring
        the system to a consistent state:

  bos.loc.utf.ZH_CN 4.1.3.0              (not installed; requisite fileset)
  bos.loc.utf.ZH_CN 4.1.3.0              (not installed; requisite fileset)
  bos.loc.utf.ZH_CN 4.1.3.0              (not installed; requisite fileset)
  X11.fnt.ucs.ttf_CN 4.2.0.0              (not installed; requisite fileset)
  X11.fnt.ucs.ttf_CN 5.3.0.0              (not installed; requisite fileset)
  bos.loc.com.bidi 4.1.0.0                (not installed; requisite fileset)
  bos.loc.iso.ko_KR 4.3.0.0              (not installed; requisite fileset)
  bos.loc.iso.ko_KR 4.1.0.0              (not installed; requisite fileset)
  bos.loc.iso.zh_TW 4.1.0.0              (not installed; requisite fileset)
  bos.loc.utf.HI_IN 5.0.0.0              (not installed; requisite fileset)
  bos.loc.utf.ZH_CN 5.3.0.0              (not installed; requisite fileset)
  bos.net.uucp 6.1.8.0                    (BROKEN)

In the 'Smitty update_all" output i have seen the below failure error too .

printers.ibmuniversal.rte 6.1.8.0        Requisite failure
printers.ibmgb18030_CN.rt 6.1.8.0        Requisite failure

I have got the below URL(FIX) for "bos.net.uucp 6.1.8.0" but after installing that the result given below. Needed some expert help.

Code:

root@[/roracle/AIX/IBM_Print_FIX]# instfix -icqk 6100-08_AIX_ML | grep :-:
6100-08_AIX_ML:bos.net.uucp:6.1.8.0:6.1.7.0:-:AIX 6100-08 Update
6100-08_AIX_ML:printers.ibmgb18030_CN.rte:6.1.8.0:6.1.6.0:-:AIX 6100-08 Update
6100-08_AIX_ML:printers.ibmuniversal.rte:6.1.8.0:6.1.6.0:-:AIX 6100-08 Update
root@[/roracle/AIX/IBM_Print_FIX]#


http://www-01.ibm.com/support/docvie...leset750555110


Regards,
Gowtham.G

AIX 6.1 New SP&TL 6.1.8.0 upgrade failed

$
0
0
Hello Team,

Hope all doing well. I have tried to upgrade on of my AIX box too the latest SP and TL, but unfortunately it's got failed(Details are below). Need expert help to fix this.


Code:

Before up-gradation :
root@[/roracle/AIX]# oslevel -s
6100-07-01-1141
root@[/roracle/AIX]# instfix -i | grep ML
    All filesets for 6100-00_AIX_ML were found.
    All filesets for 6100-01_AIX_ML were found.
    All filesets for 6100-02_AIX_ML were found.
    All filesets for 6100-03_AIX_ML were found.
    All filesets for 6100-04_AIX_ML were found.
    All filesets for 6100-05_AIX_ML were found.
    All filesets for 6100-06_AIX_ML were found.
    All filesets for 6100-07_AIX_ML were found.

While doing 'smitty upgrade_all' got failed . After reboot the machine the result's are below.

root@[/home/root]# oslevel -s
6100-07-03-1207
root@[/home/root]# instfix -i | grep ML
    All filesets for 6100-00_AIX_ML were found.
    All filesets for 6100-01_AIX_ML were found.
    All filesets for 6100-02_AIX_ML were found.
    All filesets for 6100-03_AIX_ML were found.
    All filesets for 6100-04_AIX_ML were found.
    All filesets for 6100-05_AIX_ML were found.
    All filesets for 6100-06_AIX_ML were found.
    All filesets for 6100-07_AIX_ML were found.
    All filesets for 6.1.0.0_AIX_ML were found.
    Not all filesets for 6100-08_AIX_ML were found.

root@[/home/root]# instfix -icqk  6100-08_AIX_ML | grep :-:
6100-08_AIX_ML:bos.net.uucp:6.1.8.0:6.1.7.0:-:AIX 6100-08 Update
6100-08_AIX_ML:devices.pciex.151438c1.rte:6.1.7.15:6.1.7.0:-:AIX 6100-08 Update
6100-08_AIX_ML:printers.ibmgb18030_CN.rte:6.1.8.0:6.1.6.0:-:AIX 6100-08 Update
6100-08_AIX_ML:printers.ibmuniversal.rte:6.1.8.0:6.1.6.0:-:AIX 6100-08 Update
root@[/home/root]# lppchk -v
lppchk:  The following filesets need to be installed or corrected to bring
        the system to a consistent state:

  bos.loc.utf.ZH_CN 4.1.3.0              (not installed; requisite fileset)
  bos.loc.utf.ZH_CN 4.1.3.0              (not installed; requisite fileset)
  bos.loc.utf.ZH_CN 4.1.3.0              (not installed; requisite fileset)
  X11.fnt.ucs.ttf_CN 4.2.0.0              (not installed; requisite fileset)
  X11.fnt.ucs.ttf_CN 5.3.0.0              (not installed; requisite fileset)
  bos.loc.com.bidi 4.1.0.0                (not installed; requisite fileset)
  bos.loc.iso.ko_KR 4.3.0.0              (not installed; requisite fileset)
  bos.loc.iso.ko_KR 4.1.0.0              (not installed; requisite fileset)
  bos.loc.iso.zh_TW 4.1.0.0              (not installed; requisite fileset)
  bos.loc.utf.HI_IN 5.0.0.0              (not installed; requisite fileset)
  bos.loc.utf.ZH_CN 5.3.0.0              (not installed; requisite fileset)
  bos.net.uucp 6.1.8.0                    (BROKEN)

In the 'Smitty update_all" output i have seen the below failure error too .

printers.ibmuniversal.rte 6.1.8.0        Requisite failure
printers.ibmgb18030_CN.rt 6.1.8.0        Requisite failure

I have got the below URL(FIX) for "bos.net.uucp 6.1.8.0" but after installing that the result given below. Needed some expert help.

Code:

root@[/roracle/AIX/IBM_Print_FIX]# instfix -icqk 6100-08_AIX_ML | grep :-:
6100-08_AIX_ML:bos.net.uucp:6.1.8.0:6.1.7.0:-:AIX 6100-08 Update
6100-08_AIX_ML:printers.ibmgb18030_CN.rte:6.1.8.0:6.1.6.0:-:AIX 6100-08 Update
6100-08_AIX_ML:printers.ibmuniversal.rte:6.1.8.0:6.1.6.0:-:AIX 6100-08 Update
root@[/roracle/AIX/IBM_Print_FIX]#


http://www-01.ibm.com/support/docvie...leset750555110


Regards,
Gowtham.G

Moderator's Comments:
edit by bakunin: corrected thread title to make it easier searchable

List LPAR from VIOS

$
0
0
Hi guys,

does anyone know how to get a list of the LPAR running on VIOS?

Thanks!

[Vim] Question about syntax highlighting

$
0
0
Hi all,

my sysadmin installed Vim packages (vim-enhanced-6.3-1 & vim-common-6.3-1) on an Aix system (7.1.0.0).

I log in using Putty (vs 0.54) and got an annoying underline issue. All strings and var names are underlined as you can see on the attached file Attachment 3831

Is it possible to get rid of that functionnality ?

Thank You
Please find hereafer my vimrc configuration file :
Code:

set nocompatible        " Use Vim defaults (much better!)
set backspace=2        " allow backspacing over everything in insert mode
                        " Now we set some defaults for the editor
set autoindent          " always set autoindenting on
set textwidth=72        " Don't wrap words by default
set nobackup            " Don't keep a backup file
set viminfo='20,\"50    " read/write a .viminfo file, don't store more than
                        " 50 lines of registers
set history=50          " keep 50 lines of command line history
set ruler              " show the cursor position all the time

" Vim5 comes with syntaxhighlighting. If you want to enable syntaxhightlighting
" by default uncomment the next three lines.
" Patrick ... 3 lignes suivantes décommentées
if has("syntax")
  syntax on            " Default to no syntax highlightning
  hi Comment ctermfg=DarkMagenta
endif

set showcmd            " Show (partial) command in status line.
set showmatch          " Show matching brackets.
set ignorecase          " Do case insensitive matching
set noincsearch        " Incremental search
set autowrite          " Automatically save before commands like :next and :makeset nohlsearch
set nohlsearch
" set mouse=a
set shiftwidth=2


Attached Images
File Type: png vimhl.png (17.3 KB)

Help with lv

$
0
0
Hi

In my server the lv fslv05 alone is not mirrored. Can some one explain the steps so that this lv too gets mirrored.

Code:

sapsitgp# lsvg -l rootvg

hd5                boot      1      2      2    closed/syncd  N/A
hd6                paging    4      8      2    open/syncd    N/A
paging00            paging    80      160    2    open/syncd    N/A
hd11admin          jfs2      1      2      2    open/syncd    /admin
hd8                jfs2log    1      2      2    open/syncd    N/A
hd4                jfs2      2      4      2    open/syncd    /
hd2                jfs2      16      32      2    open/syncd    /usr
hd9var              jfs2      8      16      2    open/syncd    /var
hd3                jfs2      5      10      2    open/syncd    /tmp
hd1                jfs2      2      4      2    open/syncd    /home
hd10opt            jfs2      3      6      2    open/syncd    /opt
fslv01              jfs2      1      2      2    open/syncd    /var/log
fslv02              jfs2      1      2      2    open/syncd    /usr/local
fslv03              jfs2      3      6      2    open/syncd    /patrol
lg_dumplv          sysdump    12      12      1    open/syncd    N/A
hd7x                sysdump    12      12      1    open/syncd    N/A
fslv05              jfs2      4      4      1    open/syncd    /home/db2inst2


Code:

sapsitgp# lsvg rootvg

VOLUME GROUP:      rootvg                  VG IDENTIFIER:  00c3ed9f00004c000000013acab707ae
VG STATE:          active                  PP SIZE:        128 megabyte(s)
VG PERMISSION:      read/write              TOTAL PPs:      1092 (139776 megabytes)
MAX LVs:            256                      FREE PPs:      754 (96512 megabytes)
LVs:                21                      USED PPs:      338 (43264 megabytes)
OPEN LVs:          19                      QUORUM:        2 (Disabled)
TOTAL PVs:          2                        VG DESCRIPTORS: 3
STALE PVs:          0                        STALE PPs:      0
ACTIVE PVs:        2                        AUTO ON:        no
MAX PPs per VG:    32512
MAX PPs per PV:    1016                    MAX PVs:        32
LTG size (Dynamic): 256 kilobyte(s)          AUTO SYNC:      no
HOT SPARE:          no                      BB POLICY:      relocatable
PV RESTRICTION:    none                    INFINITE RETRY: no

Code:

sapsitgp# lslv fslv05

LOGICAL VOLUME:    fslv05                VOLUME GROUP:  rootvg
LV IDENTIFIER:      00c3ed9f00004c000000013acab707ae.17 PERMISSION:    read/write
VG STATE:          active/complete        LV STATE:      opened/syncd
TYPE:              jfs2                  WRITE VERIFY:  off
MAX LPs:            512                    PP SIZE:        128 megabyte(s)
COPIES:            1                      SCHED POLICY:  parallel
LPs:                4                      PPs:            4
STALE PPs:          0                      BB POLICY:      relocatable
INTER-POLICY:      minimum                RELOCATABLE:    yes
INTRA-POLICY:      edge                  UPPER BOUND:    32
MOUNT POINT:        /home/db2inst2        LABEL:          /home/db2inst2
MIRROR WRITE CONSISTENCY: on/ACTIVE
EACH LP COPY ON A SEPARATE PV ?: yes
Serialize IO ?:    NO
INFINITE RETRY:    no

AIX 5300-05-06-0000 to 5300-09-00-0846 FAILED

$
0
0
I'm having this trouble when smit update_all.

Code:

==========================================================
MISSING REQUISITES:  The following filesets are required by one or more
  of the selected filesets listed above.  They are not currently installed
  and could not be found on the installation media.

    bos.adt.lib 5.3.9.0                      # Base Level Fileset
    bos.rte.devices 5.3.9.0                  # Base Level Fileset
    bos.rte.odm 5.3.8.0                      # Base Level Fileset
    devices.common.rspcbase.rte 5.3.8.0      # Base Level Fileset
    devices.graphics.com 5.3.9.0              # Base Level Fileset
    devices.pci.isa.rte 5.3.9.0              # Base Level Fileset
    devices.scsi.ses.rte 5.3.8.0              # Base Level Fileset
    devices.tty.rte 5.3.9.0 

==========================================================
lslpp -l |grep bos.adt.lib
  bos.adt.lib              5.3.0.50  COMMITTED  Base Application Development

==========================================================
installp -ld /usr/patch/5300-09-00-0846  #Do not show  bos.adt.lib as expected

My doubt, is there a bos.adt.lib 5.3.9.0 on this TL ? why can't I install it

Moderator's Comments:
please use code tags

Questions about setting up GPFS

$
0
0
Hello, I need to test whether our product will work with GPFS filesystems and I have some questions regarding the setup:

1. Do I need to dedicate an entire hard disk if I want to have GPFS on it? Or can I somehow split a disk into 2 virtual disks, and only use 1 for gpfs?
2. If lspv returns "none" that means the disk is connected but has not been allocated, and thus available for use in GPFS setup?
Example (hdisk3):
Code:

[root@aix01: /]# lspv
hdisk0          00ca0c3546524b4e                    rootvg          active
hdisk1          00ca0c35797dab06                    vg1            active
hdisk2          00ca0c35797daba9                    vg1            active
hdisk3          none                                None
hdisk4          00ca0c35645c51bf                    san1            active
hdisk5          00ca0c3564646ef3                    san2            active

3. Do I have to have a second node in order to create a cluster and create a gpfs on that cluster? Or can I start with one node (just to test functionality) and add a second node later? (basically, can I use that one system above with hdisk3 available to test gpfs on its own?)

Thanks in advance

Not using all CPU's?

$
0
0
Hi guys,

I am a bit confused here,

I have attached the nmon report extracted from one of my systems.

I've never seen something like this. It appears that all the cpu usage is being utilized on one CPU and the others appear to be idle or hardly used. I've seen this in a few systems recently. Now I know that their paging space is not setup correctly. and I'm going though the steps to show them that it needs to be changed. I have attached a simplified nmon log if someone can look at it and tell me if they can see why only one cpu is being utilized would be great as I've not seen this before.

Here is the lparstat

Code:

Partition Number                          : 4
Type                                      : Shared-SMT-4
Mode                                      : Capped
Entitled Capacity                          : 4.00
Partition Group-ID                        : 32772
Shared Pool ID                            : 0
Online Virtual CPUs                        : 40
Maximum Virtual CPUs                      : 60
Minimum Virtual CPUs                      : 1
Online Memory                              : 65536 MB
Maximum Memory                            : 131072 MB
Minimum Memory                            : 4096 MB
Variable Capacity Weight                  : 0
Minimum Capacity                          : 0.10
Maximum Capacity                          : 6.00
Capacity Increment                        : 0.01
Maximum Physical CPUs in system            : 16
Active Physical CPUs in system            : 16
Active CPUs in Pool                        : 16
Shared Physical CPUs in system            : 16
Maximum Capacity of Pool                  : 1600
Entitled Capacity of Pool                  : 1500
Unallocated Capacity                      : 0.00
Physical CPU Percentage                    : 10.00%
Unallocated Weight                        : 0
Memory Mode                                : Dedicated
Total I/O Memory Entitlement              : -
Variable Memory Capacity Weight            : -
Memory Pool ID                            : -
Physical Memory in the Pool                : -
Hypervisor Page Size                      : -
Unallocated Variable Memory Capacity Weight: -
Unallocated I/O Memory entitlement        : -
Memory Group ID of LPAR                    : -
Desired Virtual CPUs                      : 40
Desired Memory                            : 65536 MB
Desired Variable Capacity Weight          : 0
Desired Capacity                          : 4.00
Target Memory Expansion Factor            : -
Target Memory Expansion Size              : -
Power Saving Mode                          : Disabled

During that day here was the nmon uptime:

Code:

    12:04AM  up 2 days, 9 hrs,  0 users,    load average: 39.55, 42.90, 44.14

Attached Files
File Type: zip nmonreport-11192012.zip (941.2 KB)

Move directory

$
0
0
Hi All,

please help me with the command for moving/copying one directory(including subdirectories) to one directory in another mount point in same server in AIX ...


thanksss

AIX file system tuning

$
0
0
how do i determine the percentage of the following befor i install oracle 11g


maxperm%

maxclient%

v_pinshm

lgpg_regions

lgpg_size

Protecting backup with password

$
0
0
Hello AIX experts,

How can I protect my backups using password?
I'm waiting any solution.

Thanks

Sysback command line

$
0
0
We used sysback to backup some older servers and now need to restore some of the directories within a file system. I've tried to use smitty sysback to list the content of the file system but there are over 3000 entries. I'm looking for a command that would allow me to list out the directories to a file so I can send it to the group that wants the restore and they can specify which directories need to be restored.
Viewing all 373 articles
Browse latest View live