Quantcast
Channel: UNIX and Linux Forums - AIX
Viewing all 373 articles
Browse latest View live

Explanation of C Compiler for AIX

$
0
0
Hi, I have the following packages installed on my AIX server

xlC.aix50.rte 10.1.0.2 COMMITTED XL C/C++ Runtime for AIX 5.3
xlC.cpp 9.0.0.0 COMMITTED C for AIX Preprocessor
xlC.msg.en_US.cpp 9.0.0.0 COMMITTED C for AIX Preprocessor
xlC.msg.en_US.rte 10.1.0.2 COMMITTED XL C/C++ Runtime
xlC.rte 10.1.0.2 COMMITTED XL C/C++ Runtime


Q1. Are the preprocessors actually a C compiler ?

Q2. Are the above pre-processors some sort of cut down compiler, as I am wondering how this differs from the IBM compiler delivered via vacpp.cmp.tools ?

Q3. What is the Runtime Environment ( RTE ) - how does it differ from the compiler and the linker ( I believe the linker gets installed separately using the xlcpp.util utilities package ? )


any wisdom greatly appreciated,
Jim

IBM SAN TO SAN Mirroring

$
0
0
Has anyone tried SAN to SAN mirroring on IBM DS SAN Storage.

DS5020 mentions Enhanced Remote Mirror to multi-LUN applications

I wonder if Oracle High availibility can be setup using Remote Mirror option of SAN ?

X11 Font problem

$
0
0
Currently ,we use Exceed,X-Win32,winaxe 7.7,Reflection X software for doing evaluation.

1.Chinese word problem
When we use "more filename" to check the file in xterm command console mode from our client Window XP to IBM AIX server.it can show the chinese word,but when we change to grahpic mode by using SAS software,it can't show the chinese words properly.Any font or other method can be used to solved this problem?



2.Also,we want to type number (those number located in right side of keyboard) but it type nothing currently.



Thanks for your help if above two problem can be solved .

How to rename NSD disk names in AIX - GPFS three node cluster?

$
0
0
Hi,

i removed some nsd disks and recreated to change the pool name.
below is the nsd details

Disk details before recreation

File system Disk name NSD servers
seismic gpfs1nsd (directly attached)
seismic gpfs2nsd (directly attached)
seismic gpfs3nsd (directly attached)
(free disk) gpfs4nsd (directly attached)
(free disk) gpfs5nsd (directly attached)
(free disk) gpfs6nsd (directly attached)
(free disk) gpfs7nsd (directly attached)
(free disk) gpfs8nsd (directly attached)
(free disk) gpfs9nsd (directly attached)

Disk details after recreation of nsd

File system Disk name NSD servers
seismic gpfs1nsd (directly attached)
seismic gpfs2nsd (directly attached)
seismic gpfs3nsd (directly attached)
(free disk) gpfs11nsd (directly attached)
(free disk) gpfs12nsd (directly attached)
(free disk) gpfs13nsd (directly attached)
(free disk) gpfs14nsd (directly attached)
(free disk) gpfs15nsd (directly attached)
(free disk) gpfs16nsd (directly attached)

Here Disk Name sequence was changed after regeneration of nsd disk. How to get the previous sequence ie from gpfs1nsd to gpfs9nsd. Whats is the impact if i continue with new sequence of names. This s a three node GPFS cluster environment.

Thanks in advance.
Regin

Simple AWK cleanup/questions AIX

$
0
0
I have an unfortunate need to redo a bunch of disk settings on a VIOS on AIX, so I was putting together a quick script to scrub everything it has, make the changes, and then put the mappings back. It works, I just am trying to get my awk a bit more up-to-snuff and wanted to know the proper way to conjoin my awk statements

Initial Output:
Code:

$ lsmap -vadapter vhost3
vhost3          XXXXX.XXX.XXXXXXXX-XX-XXX                    0x00000007

VTD                  xxxx_datavg1
Status                Available
LUN                  0x8400000000000000
Backing device        hdisk41
Physloc              XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
Mirrored              false

VTD                  xxxx_rootvg1
Status                Available
LUN                  0x8500000000000000
Backing device        hdisk44
Physloc              XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
Mirrored              false

VTD                  xxxx_rootvg2
Status                Available
LUN                  0x8600000000000000
Backing device        hdisk45
Physloc              XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
Mirrored              false

What I have (and desired output)
Code:

$ lsmap -vadapter vhost3| awk '/^VTD|^Backing/' | awk 'ORS=NR%2?FS:RS'| awk '{print $2,$5}'
xxxx_datavg1 hdisk41
xxxx_rootvg1 hdisk44
xxxx_rootvg2 hdisk45

Learning awk hack and slash as I go, and I'm sure missing important fundamentals, but would appreciate the help on cleaning this up into a coherent single awk call.

How to check the Files in GB ?

$
0
0
Hi,

Can anybody give me the command in AIX to check the file sizes in GB instead of MB or KB ?


Regards,
Aparna.

Sysdump on local disk

$
0
0
Hello Team,

Our p740 systems are booting up from SAN. We would like to configure the local disk(which is not part of rootvg) as a primary dump device. I have assigned the same too. But in the errpt throwing the below error. Please help me on this.


Code:

---------------------------------------------------------------------------
LABEL:          DMPCHK_NODUMPACCESS
IDENTIFIER:    6D87B1C0

Date/Time:      Sun Oct 21 15:00:13 GMT+03:00 2012
Sequence Number: 68138
Machine Id:      00F69DD24C00
Node Id:        hostname
Class:          O
Type:            UNKN
WPAR:            Global
Resource Name:  dumpcheck

Description
The dump device can not be accessed

Probable Causes
The access to the dump device is currently unavailable

        Recommended Actions
        Check the dump device access and configuration.

Detail Data
Dump Device
hdisk0
root@[/home/root]# sysdumpdev -l
primary              /dev/hdisk0
secondary            /dev/sysdumpnull
copy directory      /var/adm/ras
forced copy flag    TRUE
always allow dump    TRUE
dump compression    ON
type of dump        traditional
root@[/home/root]#  sysdumpdev -e
0453-041 Estimated dump size in bytes: 873254092
root@[/home/root]# bootinfo -s hdisk0
25600
root@[/home/root]#lsdev -Cc disk | grep hdisk0
hdisk0      Available          Virtual SCSI Disk Drive
root@[/home/root]# lspv | grep hdisk0
hdisk0          00f69dd24640c289                    dumpvg          active
root@[/home/root]#lsvg -l rootvg  | grep dump
livedump            jfs2      4      4      1    open/syncd    /var/adm/ras/livedump
pridump            sysdump    10      10      1    closed/syncd  N/A

:wall:
Regards,
Gowtham.G

How to decompile or decode an executable?

$
0
0
I have a file type of: executable (RISC System/6000 V3.1) or obj module not stripped

How can I decode it? I know that this may be somewhat involved, but if you could steer me in the right direction, I would appreciate it. Thanks!

How much total and free memory I have in my aix 5.3 server?

$
0
0
good morning,
how I can know how much total and free memory I have in my AIX 5.3 server, and this is shown in megabytes or gigabytes?

Thank you very much.

putty background colour change in vi editor

$
0
0
Hello,

I have a problem with my putty session when i use the vi editor or when i do dbaccess on an Informix database.
Suddenly the background and foreground colour of my terminal change and it makes it difficult for me to see whats on the screen.
Why this is happening? Is there a way to keep the same background and foreground colour when i use vi also?
by the way my os is AIX 6.1 if it makes any difference.

Thank you in advance.

Command File

$
0
0
Could someone explain the below declaration, what it means exactly in the script

Code:

CMDPASS=/home/mediaserv/.ssh/client/SRVSQL25/pass_cmd.exp
Also this
Code:

info=/home/programs/tempftpinfo1_$$


Successful user login, yet system claims invalid info

$
0
0
I have four AIX 6.1.7.4 systems freshly built and ready for our DBAs to do their work. Of the three one runs into an odd issue while logging in as himself, using Putty with ssh protocols. He logs in successfully, but also gets the following error message:

[compat]: 3004-300 You entered an invalid login name or password.

But instead of dumping him, it lets him right in and proceeds as normal. There's nothing in his .profile that has him trying to be someone else and his entry in /ets/security/user is identical to systems in production. If I su from root to his ID, I don't see the message.

What am I missing here?

HMC - tracking dlpar

$
0
0
I am trying to generate a report to track dlpar operation performed on a MS and was wondering if anyone has done this before.

I can get history from HMC using lssvcevents , but this does not give me details as to what quantity was added or removed .

Any thoughts ?

Thanks

/etc/security/limits value change

$
0
0
Hello,

I have changed the value for one user in /etc/security/limit via root user

as paul:
Code:

      time(seconds) unlimited
      file(blocks) 2097151
      data(kbytes) unlimited
      stack(kbytes) unlimited
      memory(kbytes) unlimited
      coredump(blocks) unlimited
      nofiles(descriptors) unlimited

Now, when i am logging in via user paul to check the effective limits
via limits -a

It is showing me the new limits

How to get new limits effective? please help me...

Moderator's Comments:
edit by bakunin: please use CODE-tags, not only for code but also for terminal output and data. It enhances readability greatly and sets apart your describing text and the data you provide. Thank you.

FTP connection refused from text editor while accessing AIX server .

$
0
0
HI ,

I'm facing the FTP connection refused from text editor while accessing AIX server .It showing the messege "can't create ftp connection connectin refused".Though it is accessible from putty .

i'm using aix version 6 .

Can any one let me know the seetings needs to be made so that i can access the files in them from texteditors like editplus etc...

Regards,
GANESH.G.

Strange memory behavior

$
0
0
Hello together,

i have a strange memory behavior on a AIX 7.1 System, which i cannot explain.
The Filesystem-Cache will not be grow up and drops often after few minutes. I know if a file was deleted, that the same segment in the FS-Cache will also be cleared. But i am not sure if this is the correct explanation for "my" behavior.

In one test i read a file (dd if=<some file> of=/dev/null) and after the dd finished the fs-cache (file pages) immediately droped out of the memory, but i couldn't reproduce this test.

Does anyone have an idea?
Thanks

P.S.
- tunables like vmo or schedo was not changed
- the System has a lot of nfs V3 exports

Code:

# vmstat -v
              6553600 memory pages
              6274304 lruable pages
              3778457 free pages
                    2 memory pools
              1204754 pinned pages
                90.0 maxpin percentage
                  3.0 minperm percentage
                90.0 maxperm percentage
                  5.4 numperm percentage
              342616 file pages
                  0.0 compressed percentage
                    0 compressed pages
                  5.4 numclient percentage
                90.0 maxclient percentage
              342558 client pages
                    0 remote pageouts scheduled
                34333 pending disk I/Os blocked with no pbuf
                    0 paging space I/Os blocked with no psbuf
                2228 filesystem I/Os blocked with no fsbuf
                73667 client filesystem I/Os blocked with no fsbuf
              284352 external pager filesystem I/Os blocked with no fsbuf
                37.1 percentage of memory used for computational pages

Code:

#lparstat -i
Type                                      : Shared-SMT-4
Mode                                      : Uncapped
Entitled Capacity                          : 2.00
Partition Group-ID                        : 32820
Shared Pool ID                            : 3
Online Virtual CPUs                        : 4
Maximum Virtual CPUs                      : 8
Minimum Virtual CPUs                      : 1
Online Memory                              : 25600 MB
Maximum Memory                            : 61440 MB
Minimum Memory                            : 2048 MB
Variable Capacity Weight                  : 4
Minimum Capacity                          : 0.10
Maximum Capacity                          : 4.00
Capacity Increment                        : 0.01
Maximum Physical CPUs in system            : 64
Active Physical CPUs in system            : 32
Active CPUs in Pool                        : 12
Shared Physical CPUs in system            : 12
Maximum Capacity of Pool                  : 3200
Entitled Capacity of Pool                  : 420
Unallocated Capacity                      : 0.00
Physical CPU Percentage                    : 50.00%
Unallocated Weight                        : 0
Memory Mode                                : Dedicated
Total I/O Memory Entitlement              : -
Variable Memory Capacity Weight            : -
Memory Pool ID                            : -
Physical Memory in the Pool                : -
Hypervisor Page Size                      : -
Unallocated Variable Memory Capacity Weight: -
Unallocated I/O Memory entitlement        : -
Memory Group ID of LPAR                    : -
Desired Virtual CPUs                      : 4
Desired Memory                            : 25600 MB
Desired Variable Capacity Weight          : 4
Desired Capacity                          : 2.00
Target Memory Expansion Factor            : -
Target Memory Expansion Size              : -
Power Saving Mode                          : Disabled


Attached Images
File Type: jpg memory.jpg (101.6 KB)

[Solved] /etc/security/limits value change

$
0
0
Hello,

I have changed the value for one user in /etc/security/limit via root user

as paul:
Code:

      time(seconds) unlimited
      file(blocks) 2097151
      data(kbytes) unlimited
      stack(kbytes) unlimited
      memory(kbytes) unlimited
      coredump(blocks) unlimited
      nofiles(descriptors) unlimited

Now, when i am logging in via user paul to check the effective limits
via limits -a

It is showing me the new limits

How to get new limits effective? please help me...

Moderator's Comments:
edit by bakunin: please use CODE-tags, not only for code but also for terminal output and data. It enhances readability greatly and sets apart your describing text and the data you provide. Thank you.

syslog rotation problem

$
0
0
i have added below two lines in syslog.conf file. Is there anything wrong in the below lines?
Code:


*.info                  /var/adm/syslog rotate time 1d files 10
local0.debug            /var/adm/conserv.log rotate time 1d files 10

Though I have restarted syslogd with the below commands, log rotation is not happening. Could anyone help me in this regard..
Code:

/usr/bin/stopsrc -s syslogd
/usr/bin/startsrc -s syslogd

Moderator's Comments:
Please use code tags next time for your code and data.

cpu used more than 80% how will u trouble shoot?

$
0
0
cpu used more than 80% how will u trouble shoot?

memory is more than 80% how will u trouble shoot it?

$
0
0
memory is more than 80% how will u trouble shoot it?
Viewing all 373 articles
Browse latest View live