Quantcast
Channel: UNIX and Linux Forums - AIX
Viewing all 373 articles
Browse latest View live

send SMS via curl

$
0
0
I need from aix to send an SMS, you know if the command curl serves me

Restore file from mksysb file

$
0
0
Hello,

I have a mksysb backup OS image. I can restore the file from there, but the issue is the restored file include the whole path :confused:

Code:

listvgbackup -f /backup/xxx/mksysb.xxx.20190316 -r -s -d /home/aaa/ ./home/bbb/nohup.out
I plan to restore nohup.out from /home/bbb/nohup.out to /home/aaa/nohup.out.

But actually I see this:
Code:

[root@xxx] / > ls -l /home/aaa/home/bbb/nohup.out
-rw-------    1 root    system      1585567 Jun 28 2013  /home/aaa/home/bbb/nohup.out

It takes the whole path & file to new destination.

Can everybody advise me on this?

Regards,
Phat

Curl, to send text message

$
0
0
hello friends I need to send a text message MSM by AIX with a function called CURL you have some example of how it is done so that you can help me please

Sense Data Layout

$
0
0
On AIX 7.1 we have errors with SC_DISK_ERR4 label.

In document "Fibre Channel Planning and Integration: User's Guide and Service Information" I can find SENSE Data description in section "PCI Fibre Channel Adapter, SCSI-3 Protocol (Disk, CD-ROM, Read/Write Optical Device) Error Log Sense Information". But there is no description of value in our case:

We have next Sense Data in our errpt output:

SENSE DATA
Code:

1000 8800 0000 0002 66BA DAD0 0000 0010 0004 0000 0000 0000 0140 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0271 7B16 000C D680 0000 0000 0000 0000 0000 0000 0000 0083 0010
0002 006E 001D

So if we check field Status Validity and SCSI Status field, we have next value:
01 - Indicates that the SCSI Status field (SS) is valid
40 - ??? (the value in document is only 02, 08, 18)

Or may be i don't correctly understand this error log sense information.
So, can you give me link for document described Sense Data layout for SC_DISK_ERR4 errors, or may be you can explain how to interpreted this fields
Thank you.

AIX extend VG error

$
0
0
Hi,

I have encountered the issue of extending VG:
Here is my command
Code:

[root@xxx] / > extendvg vg1 hdisk39
0516-1162 extendvg: Warning, The Physical Partition Size of 128 requires the
        creation of 8192 partitions for hdisk39.  The limitation for volume group
        tsm_stg is 3048 physical partitions per physical volume.  Use chvg command
        with -t option to attempt to change the maximum Physical Partitions per
        Physical volume for this volume group.
0516-792 extendvg: Unable to extend volume group.

Have try chvg -t but
Code:

[root@xxx] / > chvg -t 6 vg1
0516-1780 lchangevg: Volume group conversion is not possible since the factor value
        of 6 can accommodate at most 21 physical volumes.
0516-732 chvg: Unable to change volume group vg1.

Code:

[root@xxx] / > lsvg vg1
VOLUME GROUP:      vg1                  VG IDENTIFIER:  00f8337b00004c0000000146cc959f6b
VG STATE:          active                  PP SIZE:        128 megabyte(s)
VG PERMISSION:      read/write              TOTAL PPs:      46359 (5933952 megabytes)
MAX LVs:            512                      FREE PPs:      132 (16896 megabytes)
LVs:                6                        USED PPs:      46227 (5917056 megabytes)
OPEN LVs:          6                        QUORUM:        15 (Enabled)
TOTAL PVs:          29                      VG DESCRIPTORS: 29
STALE PVs:          0                        STALE PPs:      0
ACTIVE PVs:        29                      AUTO ON:        yes
MAX PPs per VG:    130048
MAX PPs per PV:    4064                    MAX PVs:        32
LTG size (Dynamic): 256 kilobyte(s)          AUTO SYNC:      no
HOT SPARE:          no                      BB POLICY:      relocatable
PV RESTRICTION:    none                    INFINITE RETRY: no
DISK BLOCK SIZE:    512

Any advice if I can change the parameter "MAX PPs per PV"?

I can see other VG has big number
Code:

[root@xxx] / > lsvg vg2
VOLUME GROUP:      vg2                VG IDENTIFIER:  00f8337b00004c000000015451842ab7
VG STATE:          active                  PP SIZE:        128 megabyte(s)
VG PERMISSION:      read/write              TOTAL PPs:      40955 (5242240 megabytes)
MAX LVs:            512                      FREE PPs:      32454 (4154112 megabytes)
LVs:                2                        USED PPs:      8501 (1088128 megabytes)
OPEN LVs:          2                        QUORUM:        3 (Enabled)
TOTAL PVs:          5                        VG DESCRIPTORS: 5
STALE PVs:          0                        STALE PPs:      0
ACTIVE PVs:        5                        AUTO ON:        yes
MAX PPs per VG:    128016
MAX PPs per PV:    9144                    MAX PVs:        14
LTG size (Dynamic): 256 kilobyte(s)          AUTO SYNC:      no
HOT SPARE:          no                      BB POLICY:      relocatable
PV RESTRICTION:    none                    INFINITE RETRY: no
DISK BLOCK SIZE:    512

Pinned system memory growing constantly

$
0
0
Hi,

Pre data: a server running AIX 6.1 TL9 with 2GB memory and a small amount of CPU, running a very light workload.

I have a server which crashed on lack of memory. After the crash I found - using nmon analyser - that there was something eating up memory. Nmon referred to it as "system".

Now, after 2 days of uptime I see that the same "someting" is eating up memory again. I've been using nmon, vmstat and svmon to see what is happening, but all I see is that
- all user process is using the same amount of memory
- vmstat shows a steady decrease on free list
- svmon -G shows the same steady amount of memory being pinned
- svmon -P shows that there is no change of pinned memory usage in the listed processes
The rate of memory loss is about 0.5% in every hour.

So I assume that some kernel related object is accumulating the pinned memory.

Can you please help me to find out the problematic part?

Additional info: there was a reported bug in AIX7.2 which have been corrected in an update. But: this machine was running for a while without any problems.

--Trifo

Unable to mount previously-working NFS share from NIM to LPAR

$
0
0
Right, now that I've finally worked out this website, I'll ask my question!

I am having an absolute nightmare with NFS on AIX. I have used it many times, and I know what I'm doing, however I cannot fathom what is going on here. I have 2 LPARs, sitting on the same physical host. They are configured with an internal and external network. The internal network is being used here. Nothing has changed since this was working, as far as the network connections go. However, when I mount any exported filesystems from NIM to LPAR1, I get a timeout:

nfsmnthelp: NIMsvr: Connection timed out

I have checked the following:

1. /etc/hosts is correct on both, and I have tried using both networks
2. NFS is started on both NIM and LPAR1. I have tried restarting the services using `stopsrc -g nfs; stopsrc -s portmap` then starting them again
3. Stopping services, then running `rm -rf /etc/state /etc/sm /etc/sm.bak /etc/xtab /etc/rmtab; startsrc -s portmap; startsrc -g nfs; exportfs -a; showmount -e NIMsvr`. The last command shows the mount is available
4. Removing the export from NIM, removing it from LPAR1, then restarting NFS on both NIM and LPAR1, adding the mount back in and re-mounting (checking showmount -e before adding back in and after, and the mount shows up the second time)
5. Telnet to port 111 from LPAR1 to NIM works fine

I am out of ideas, can anyone help please? I am about to pull my last few hairs out!

AIX 7.2 MKSYSB Backup and Restore Best Practices?

$
0
0
Hello,

Running AIX 7.2 on Power9 bare-metal (no LPAR and no NIM server), in the process of creating a guide on MKSYSB process.

I understand that MKSYSB is a backup of the rootvg and we can exclude stuff via exclude.rootvg file, the rest of the data volumes are mapped to the system as LUNs via multi-path FC connection to a SAN and that is backed up separately. The rootvg does not boot off SAN, it has two internal NVMe disks.

In the event that rootvg is corrupt and we need to restore rootvg , the process would be to modify the bootlist and reboot into SMS via SSH/Console or using the ASMI service processor.

Are there any critical steps we need to do pre or post-rootvg restore?
  • Currently the rootvg is mirrored, once restored will it remain mirrored?
  • Will i need to mess with the bootlist at all?
  • Will the configuration of the external filesystems be preserved and mounted ready to use (if set to auto-mount at boot)?
  • Running a power system in 24x7 prodution after a MKSYSB restore is viable or should one plan for a fresh re-install of AIX from install media at some point?
  • Does one need access to AIX 7.2 install media at any point during a MKSYSB restore?

The Power9 system has a LTO tape library which is where I was going to write the MKSYSB backup to and boot off, there is no CD-ROM but there is USB - is it possible to boot MKSYSB off USB? Any cons or pros going with tape vs. USB? Most of the guides out there refer to a tape or dvd, though many of them were written years ago.

My plan is to learn from experience and create a MKSYSB via mksysb -iev /dev/rmt0, corrupt rootvg by rm -rf /etc, and reboot. I am pretty sure it will become very unhappy with a missing /etc - so proceed with another reboot (via FPO using Control Panel or ASMI) and boot to SMS for a MKSYSB restore.

Mainly looking for best practices / tips / suggestions around the process.

AIX hdisk Mirror vs alt_clone

$
0
0
Hello,


I have two hdisk in Power7 machine, the rootvg on hdisk0.
So to make a disk redundancy should make mirror or alt_clone and what is the different.


Appreciate your help



Thanks

[Discussion] AIX future

$
0
0
Hello,

Can someone tell me the future of AIX and its popularity? As I know there are not much companies using it and its latest version 7.2 was introduced in the long time. Many colleagues advise not to go further with it?

With my current situation, I have to maintain the environment for customer, so I have to :)

Could someone point out some figures about it such as number of companies, the value in the career path? Of course can be estimation.

Power Machine password

$
0
0
Hi,

I have installed the HMC on the VMWare VM. I try to add the power machine (managed system) and asking for a password? So this is the IBM predefined password of Power Machine?

In the VMWare perspective, we can login to ESX host to do some management tasks. But how about the Power machine? Can we login to it via ssh ( I suppose) to view some settings like CPU, RAM, Disks, ...

1 more thing, HMC is the linux right? How can we access to by using the root id? the sudo or su commands are not found.

I'm newbie to this region, so any help is very appreciated from my side :)

AIX altinst_rootvg

$
0
0
Hello,

Our NIM system becomes unresponsive while working. Look like first time that the root disk was missing. I cannot use many commands like lspv, lspath, ... ssh and other services are not operating.

I have rebooted the machine, and I can boot it to AIX, but it's an older AIX version 6.1 and not the current one 7.1

I also see that the OS is booted from hdisk0, while the current OS is booted from hdisk9. But now hdisk9 belongs to altinst_rootvg and varied off.

Look like the boot volume on hdisk9 was corrupted and system turns to the old one on hdisk0 to boot from it.

How can we re-create the boot volume on hdisk9? I tried to boot the system to single user mode on hdisk0 (old OS version), and try the bosboot command on hdisk9, but not success. It says the hd5 is already available in use.

I tried to use synclvodm and it changed my LVs on altinst_rootvg to new ones. Not sure that it just only renames the LV name, I hope it not overwrite the data on the altinst_rootvg.
Code:

# synclvodm -v altinst_rootvg
synclvodm: Physical volume data updated.
0516-530 synclvodm: Logical volume name hd6 changed to pagelv00.
synclvodm: Logical volume pagelv00 updated.
0516-530 synclvodm: Logical volume name hd8 changed to loglv02.
0516-712 synclvodm: The chlv succeeded, however chfs must now be
        run on every filesystem which references the old log name hd8.
synclvodm: Logical volume loglv02 updated.
0516-530 synclvodm: Logical volume name hd4 changed to fslv01.
synclvodm: Logical volume fslv01 updated.
0516-530 synclvodm: Logical volume name hd2 changed to fslv02.
synclvodm: Logical volume fslv02 updated.
0516-530 synclvodm: Logical volume name hd9var changed to fslv03.
synclvodm: Logical volume fslv03 updated.
0516-530 synclvodm: Logical volume name hd3 changed to fslv04.
synclvodm: Logical volume fslv04 updated.
0516-530 synclvodm: Logical volume name hd1 changed to fslv05.
synclvodm: Logical volume fslv05 updated.
0516-530 synclvodm: Logical volume name hd10opt changed to fslv06.
synclvodm: Logical volume fslv06 updated.
0516-530 synclvodm: Logical volume name hd11admin changed to fslv07.
synclvodm: Logical volume fslv07 updated.
0516-530 synclvodm: Logical volume name loglv00 changed to loglv03.
0516-712 synclvodm: The chlv succeeded, however chfs must now be
        run on every filesystem which references the old log name loglv00.
synclvodm: Logical volume loglv03 updated.
0516-530 synclvodm: Logical volume name livedump changed to fslv08.
synclvodm: Logical volume fslv08 updated.
0516-530 synclvodm: Logical volume name sec_dumplv changed to lv00.
synclvodm: Logical volume lv00 updated.
0516-530 synclvodm: Logical volume name pri_dumpdev changed to lv01.
synclvodm: Logical volume lv01 updated.

Now I'm downloading the ISO file and can boot into maintenance mode. Can we do the followings:

rename all the LVs to its original name
recreate the hd5 volume
rewrite the boot volume info with bosboot and reboot the system to boot from it.

The thing I'm not very clear is, what is altinst_rootvg? If I can create the boot volume and rename the LV successfully as above, I can boot from it?

With my research about altinst_rootvg, it's a technique to replicate the current OS, this is done by backup purpose. Still reading it for more info ...

AIX understanding memory using

$
0
0
Hello,

I would like to understand better in AIX memory use
Code:

[root@xxx] / > svmon -G -O unit=MB
Unit: MB
--------------------------------------------------------------------------------------
              size      inuse        free        pin    virtual  available  mmode
memory      9216.00    2325.38    6890.62      896.11    1943.12    6975.40    Ded
pg space  18944.00        8.48

              work        pers        clnt      other
pin          539.12          0        9.23      347.75
in use      1943.12          0      382.26

So I can say that, my total free RAM is : free (2325.38) + available (1943.12) = 4268.5 MB ???
So what are pin/virtual meaning here?

How do I set up a Zebra Printer on AIX?

$
0
0
Hi All

We have a Zebra LP 2824 that we are wanting to use to print mailing labels from our AIX 7.1 server.

We have around 350 printers of various types and manufactures already installed and functioning so, we don't want to install CUPS.

I can get the printer to print using Line Mode but, the orientation is 180 degrees out and I don't see anything in the Line Mode Programmers Manual to correct this.

Zebra does not have printer drivers for Native Unix, Linux or AIX print systems and I can't get the printer to do anything in Page Mode at all.

Has anybody been able to get Zebra Printers working correctly on an AIX server and if so, how?

Systemmirror v6.1 cluster issues.

$
0
0
We had an issue during an LPM of a cluster node that seemed to be a network related issue. After that we rebooted everything and brought it all back up but now both nodes of the cluster don't see either as being "up" (clstat). They see themselves but not the other node. One of the odd issues is that the cl_clcmd will execute a command on both nodes. I can also start cluster services on both nodes from one node. This is an active/active setup running cluster version 6.1.0 sp14

Hard drive compatibility for POWER6 p520

$
0
0
Hi, I have recently inherited an old p520 from work running AIX 6.1, based on the POWER6 CPU. I'm planning to play around with it and use it to learn the system, so this is a purely personal project. The machine is not under a support contract any more.

I am looking to replace one of the disks which might be failing. It's not the OS disk, and has nothing important on it. It works fine right now but a few errors were logged before I got it. I looked on eBay and elsewhere for a cheap replacement disk and there are many such items available. I was told that it needs to have the correct IBM firmware and formatted with 512 byte sectors. I found a couple of disks which are 146.8 GB, 15k RPM SAS with an IBM caddy (used but working, pulled from a server) and has 512 byte sectors, but listed for "Power Systems AIX/Linux". I believe "Power Systems" refers to newer CPUs like POWER7+, while my machine is a pSeries model.

My question is: can I use this disk on my POWER6 system? Is the newer firmware backward compatible? I'm an AIX newbie BTW so please be patient :)


Also generally any tips for spare parts/future replacements if anyone else also has such old machines to play with?

AIX - stale partition

$
0
0
Hi everybody,
I have a little problem with my AIX 6.1, PowerHA 6.1 LVM mirror. After problem with SAN pathing of our one Datacenter, I have LV at stale state.

Code:

# lsvg cpsdata2vg
VOLUME GROUP:      cpsdata2vg              VG IDENTIFIER:  00fb518c00004c0000000169445f4c2c
VG STATE:          active                  PP SIZE:        1024 megabyte(s)
VG PERMISSION:      read/write              TOTAL PPs:      6142 (6289408 megabytes)
MAX LVs:            256                      FREE PPs:      441 (451584 megabytes)
LVs:                2                        USED PPs:      5701 (5837824 megabytes)
OPEN LVs:          2                        QUORUM:        2 (Enabled)
TOTAL PVs:          2                        VG DESCRIPTORS: 3
STALE PVs:          1                        STALE PPs:      108
ACTIVE PVs:        1                        AUTO ON:        no
Concurrent:        Enhanced-Capable        Auto-Concurrent: Disabled
VG Mode:            Concurrent
Node ID:            1                        Active Nodes:      2 3 4
MAX PPs per VG:    32768                    MAX PVs:        1024
LTG size (Dynamic): 256 kilobyte(s)          AUTO SYNC:      no
HOT SPARE:          no                      BB POLICY:      relocatable
MIRROR POOL STRICT: off
PV RESTRICTION:    none                    INFINITE RETRY: no
DISK BLOCK SIZE:    512                      CRITICAL VG:    no

 # lspv
...
hdisk36        00fb518c4457e71a                    cpsdata2vg      concurrent
hdisk37        00fb518c4457f895                    cpsdata2vg      concurrent

 # lsvg -l cpsdata2vg
cpsdata2vg:
LV NAME            TYPE      LPs    PPs    PVs  LV STATE      MOUNT POINT
cpsabcd2lv          jfs2      2850    5700    2    open/stale    /cpsabcd2
loglv00            jfs2log    1      1      1    open/syncd    N/A

 # lsvg -p cpsdata2vg
cpsdata2vg:
PV_NAME          PV STATE          TOTAL PPs  FREE PPs    FREE DISTRIBUTION
hdisk36          active            3071        220        00..00..00..00..220
hdisk37          missing          3071        221        00..01..00..00..220


Normally I solve it by command varyonvg for non-concurrent LUNs. I cant find solutions for Enhanced-Capable concurrent LUNs.
I guess that the right way to solve this problem is command varyonvg too. With parameter '-c' for concurrent vary.

Does anyone have experience with this procedure? I cant umount this filesystem right now, so I am curious if I can do this without unavailability or other problem with filesystem.

Thank you.

IBM TDS/SDS (LDAP) - can I mix endianness among servers in an instance ?

$
0
0
I'd like to add some x/linux-based servers to my current AIX-based TDS/SDS server community. Reading the Fine Install Guide (rtfig ?) I believe this may be covered by the section "Upgrade an instance of a previous version to a different computer" i.e. I'm going to install latest/greatest SDS on a new server image, then bring in the instance data from one of my current servers.

The chart in that section of the Install Guide indicates this is only possible among systems with the same endianness.

Is it possible to have Intel & power servers cooperating on the same directory ? If so, can someone pls point me to doc on how to get there ?

Much appreciated !

[edit:] more reading. I see in the section "creating a copy of an existing instance" the same requirement that only data from a source with the same endianness as the target can be used.

So: can I create an instance copy without data, then (quiesce replication and suspend my servers and) dump the directory to an LDIF, and load the new instance from that instead of from a backup ? Then ensuring that replication is prepared on the new copy and then spinning up the whole pile ? The crux being that by importing the data as text rather than binary, I avoid the fact that handling of endianness/network byte order is missing from the deploy tools ?

Same question as above though, crudely, does replication handle network byte order correctly and swap data nice between different endiannesses ?

Samba 3.6 on AIX 7.1 - Windows 10 Access to AIX file shares using Active Directory authentication

$
0
0
I am running AIX 7.1 and currently we have samba 3.6.25 installed on the server. As it stands some AIX folders are shared that can be accessed by certain Windows users.
The problem is that since Windows 10 the guest feature no longer works so users have to manually type in their Windows login/pwd before they can access the shared drives. They get a pop up box asking them to login. Previously users were able to connect to the AIX file shares with no requirement to enter username/passwords. I do not have Kerberos installed on this server.

My requirement:
I need to reconfigure samba so that a small group of Windows users in a specific group on Active Directory can access these shared folders on AIX without the requirement to enter their login and password. Samba should recognise the user they are currently logged in as on Active Directory and allow them access to the folder if they are a member of the right access group.

My current smb.conf is as follows:

Code:

workgroup = domain
wins support = yes
security = user
log file = /var/log/samba.log
protocol = SMB2                           
min protocol = SMB2                ## This had to be added so that Windows 10 machines can access the share as SMB1 is not supported

[File Share]
path = /filetoshare/here
force user = root
read only = no
public = yes
guest ok = no

I understand from my initial research that I need to change the security from user to ADS by setting security = ADS. This would then allow me to use Active Directory to authenticate the users. Unfortunately after checking the nmbd logs it seems that this setting is not recognised by this version of Samba 3.6...

Quote:

WARNING: Ignoring invalid value 'ADS' for parameter 'security'
Ignoring unknown parameter "realm"
It may be that Samba 3.6 does not support ADS. In this case do I have any other options with Samba 3.6 that would allow me to authenticate with the Windows Domain running on Windows Server 2012? I see there is also a server setting of domain - server = domain. I understand the AIX machine name would need to be added to the active directory server under machines I presume?

When looking at adding Samba to domains there was reference to a command "net ads -u Username" I get another error.
Quote:

ADS support not compiled in
So I presume this means I can't use the domain option either which would suggest I need a newer version of Samba.

I have checked many AIX forums but have not been able to find a pre-compiled version of samba 4 for AIX 7.1. This would be the safest way to upgrade.
Unfortunately this AIX machine does not have GCC, WGET, YUM installed so it would be difficult to compile from source. If this was Ubuntu I'd just run an apt-get install samba but AIX is a different beast.
Also can anyone confirm if I need to also install Kerberos for this to work?

I'd be interested to hear if anyone has this working. Any suggestions to help with this project would be appreciated. Thank you.

Apache 2.4 directory cannot display "Last modified" "Size" "Description"

$
0
0
Hi 2 all,
i have had AIX 7.2

Code:

[root@dmdw1]:/# /usr/IBMAHS/bin/apachectl -v
Server version: Apache/2.4.12 (Unix)
Server built:  May 25 2015 04:58:27
 [root@dmdw1]:/#

Code:

[root@dmdw1]:/# /usr/IBMAHS/bin/apachectl -M
Loaded Modules:
 core_module (static)
 so_module (static)
 http_module (static)
 mpm_worker_module (static)
 authn_file_module (shared)
 authn_dbm_module (shared)
 authn_anon_module (shared)
 authn_dbd_module (shared)
 authn_socache_module (shared)
 authn_core_module (shared)
 authz_host_module (shared)
 authz_groupfile_module (shared)
 authz_user_module (shared)
 authz_dbm_module (shared)
 authz_owner_module (shared)
 authz_dbd_module (shared)
 authz_core_module (shared)
 access_compat_module (shared)
 auth_basic_module (shared)
 auth_form_module (shared)
 auth_digest_module (shared)
 allowmethods_module (shared)
 file_cache_module (shared)
 cache_module (shared)
 cache_disk_module (shared)
 cache_socache_module (shared)
 socache_shmcb_module (shared)
 socache_dbm_module (shared)
 socache_memcache_module (shared)
 watchdog_module (shared)
 macro_module (shared)
 dbd_module (shared)
 dumpio_module (shared)
 echo_module (shared)
 buffer_module (shared)
 data_module (shared)
 ratelimit_module (shared)
 reqtimeout_module (shared)
 ext_filter_module (shared)
 request_module (shared)
 include_module (shared)
 filter_module (shared)
 reflector_module (shared)
 substitute_module (shared)
 sed_module (shared)
 charset_lite_module (shared)
 deflate_module (shared)
 xml2enc_module (shared)
 proxy_html_module (shared)
 mime_module (shared)
 log_config_module (shared)
 log_debug_module (shared)
 log_forensic_module (shared)
 logio_module (shared)
 lua_module (shared)
 env_module (shared)
 mime_magic_module (shared)
 expires_module (shared)
 headers_module (shared)
 usertrack_module (shared)
 unique_id_module (shared)
 setenvif_module (shared)
 version_module (shared)
 remoteip_module (shared)
 proxy_module (shared)
 proxy_connect_module (shared)
 proxy_ftp_module (shared)
 proxy_http_module (shared)
 proxy_fcgi_module (shared)
 proxy_scgi_module (shared)
 proxy_fdpass_module (shared)
 proxy_wstunnel_module (shared)
 proxy_ajp_module (shared)
 proxy_balancer_module (shared)
 proxy_express_module (shared)
 session_module (shared)
 session_cookie_module (shared)
 session_dbd_module (shared)
 slotmem_shm_module (shared)
 slotmem_plain_module (shared)
 ssl_module (shared)
 dialup_module (shared)
 lbmethod_byrequests_module (shared)
 lbmethod_bytraffic_module (shared)
 lbmethod_bybusyness_module (shared)
 lbmethod_heartbeat_module (shared)
 unixd_module (shared)
 heartbeat_module (shared)
 heartmonitor_module (shared)
 dav_module (shared)
 status_module (shared)
 autoindex_module (shared) <-------------
 asis_module (shared)
 info_module (shared)
 cgid_module (shared)
 cgi_module (shared)
 dav_fs_module (shared)
 dav_lock_module (shared)
 vhost_alias_module (shared)
 negotiation_module (shared)
 dir_module (shared)
 imagemap_module (shared)
 actions_module (shared)
 speling_module (shared)
 userdir_module (shared)
 alias_module (shared)
 rewrite_module (shared)
[root@dmdw1]:/#


---- AIX httpd.conf



Code:

#DocumentRoot "/usr/IBMAHS/htdocs"
DocumentRoot "/home/oracle/load"
<Directory "/home/oracle/load">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    #  Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important.  Please see
    # core - Apache HTTP Server Version 2.4
    # for more information.
    #
    Options Indexes FollowSymLinks
    AddDefaultCharset windows-1251
    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    #  AllowOverride FileInfo AuthConfig Limit
    #
    AllowOverride None

    #
    # Controls who can get stuff from this server.
    #
    Require all granted
</Directory>


I upload images between linux apache directory view and AIX apache directory view. AIX cannot display "Last modified" "Size" "Description" . How to solve this issue ?

Attached Thumbnails
Click image for larger version

Name:	linux_directory12343324.png
Views:	N/A
Size:	15.3 KB
ID:	7874
Click image for larger version

Name:	aix_apache_directory.png
Views:	N/A
Size:	14.3 KB
ID:	7875
Viewing all 373 articles
Browse latest View live