Quantcast
Channel: UNIX and Linux Forums - AIX
Viewing all articles
Browse latest Browse all 373

Trouble removing Physical Disk from Volume Group

$
0
0
I want to remove hdisk1 from volume group diskpool_4 and migrate PV from hdisk1 to hdisk2 , but facing problems, so what is the quickest way to migratepv and remove hdisk1 --

Code:

# lspv | grep diskpool_4
hdisk1          00c7780e2e21ec86                    diskpool_4      active
hdisk2          00c7780ea5bd16bb                    diskpool_4      active

# lsvg -l diskpool_4
diskpool_4:
LV NAME            TYPE      LPs    PPs    PVs  LV STATE      MOUNT POINT
clodba              jfs        720    1440    2    open/stale    N/A


# lsvg diskpool_4
VOLUME GROUP:      diskpool_4              VG IDENTIFIER:  00c7780e00004c000000013c210bf284
VG STATE:          active                  PP SIZE:        256 megabyte(s)
VG PERMISSION:      read/write              TOTAL PPs:      2234 (571904 megabytes)
MAX LVs:            1024                    FREE PPs:      794 (203264 megabytes)
LVs:                1                        USED PPs:      1440 (368640 megabytes)
OPEN LVs:          1                        QUORUM:        2 (Enabled)
TOTAL PVs:          2                        VG DESCRIPTORS: 3
STALE PVs:          1                        STALE PPs:      1
ACTIVE PVs:        2                        AUTO ON:        yes
MAX PPs per VG:    1048576                  MAX PVs:        1024
LTG size (Dynamic): 256 kilobyte(s)          AUTO SYNC:      no
HOT SPARE:          no                      BB POLICY:      relocatable
MIRROR POOL STRICT: off
PV RESTRICTION:    none                    INFINITE RETRY: no
DISK BLOCK SIZE:    512                      CRITICAL VG:    no
#

# lsvg -p diskpool_4
diskpool_4:
PV_NAME          PV STATE          TOTAL PPs  FREE PPs    FREE DISTRIBUTION
hdisk2            active            1117        396        224..79..00..00..93
hdisk1            active            1117        398        184..00..01..00..213

#  lspv -l hdisk1
hdisk1:
LV NAME              LPs    PPs    DISTRIBUTION          MOUNT POINT
clodba                719    719    40..223..222..223..11 N/A
# lspv -l hdisk2
hdisk2:
LV NAME              LPs    PPs    DISTRIBUTION          MOUNT POINT
clodba                720    721    00..144..223..223..131 N/A


# migratepv -l clodba hdisk1 hdisk2
0516-076 lmigratelv: Cannot remove last good copy of stale partition.
        Resynchronize the partitions with syncvg and try again.
0516-812 migratepv: Warning, migratepv did not completely succeed;
        all physical partitions have not been moved off the PV.

# syncvg -v diskpool_4
0516-1296 lresynclv: Unable to completely resynchronize volume.
        The logical volume has bad-block relocation policy turned off.
        This may have caused the command to fail.
0516-934 /etc/syncvg: Unable to synchronize logical volume clodba.
0516-932 /etc/syncvg: Unable to synchronize volume group diskpool_4.

Check the copies of LV
Code:

# lslv -m clodba
clodba:N/A
LP    PP1  PV1              PP2  PV2              PP3  PV3
0001  0225 hdisk1            0305 hdisk2
0002  0226 hdisk1            0306 hdisk2
0003  0227 hdisk1            0307 hdisk2
0004  0228 hdisk1            0308 hdisk2
.......................................................
......................................................
.....................................................

REMOVE COPY from hdisk2

# rmlvcopy clodba 1 hdisk2


# lslv -m clodba
clodba:N/A
LP    PP1  PV1              PP2  PV2              PP3  PV3
0001  0225 hdisk1
0002  0226 hdisk1
.....................................
...............................
..................................

MigratePV from hdisk1 to hdisk2

Code:

migratepv -l clodba hdisk1 hdisk2

Viewing all articles
Browse latest Browse all 373

Trending Articles